Issues with incoming and outgoing invoices over FTP
Incident Report for PE Accounting
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 15:26 CET
Update
We are continuing to investigate this issue.
Posted Jan 15, 2024 - 11:25 CET
Investigating
We currently have problems with incoming and outgoing invoices over FTP. We are investigating.
Posted Jan 15, 2024 - 11:22 CET
This incident affected: API.